# Definir Versões Padrão de Pacotes

No ServBay, você pode definir versões padrão de pacotes para suporte à linha de comando a serem usadas por padrão ao executar comandos na linha de comando ou scripts relacionados, suportando PHP, MariaDB, PostgreSQL e muito mais. Aqui estão as instruções detalhadas para definir versões padrão de pacotes:

  1. Abra o ServBay.

  2. Clique em "Configurações" na barra de navegação à esquerda.

  3. Na página de configurações, encontre a opção "Versão Padrão".

  4. Nas opções suspensas, escolha as versões padrão para PHP, MariaDB e PostgreSQL, respectivamente.

  5. Clique no botão "Aplicar" para aplicar as alterações.

Após definir as versões padrão, por exemplo, se você definir a versão padrão do PHP como 7.4, ao executar php -v na linha de comando, será exibido PHP 7.4.x (cli).

Se você precisar executar temporariamente uma versão não padrão na linha de comando, como o PHP 8.1, você pode invocar a versão 8.1 usando o comando php-8.1, como php-8.1 -v, que exibirá PHP 8.1.x (cli).

Configurações semelhantes se aplicam ao MariaDB, PostgreSQL e outros pacotes. Observe que na página de gerenciamento de serviços, você pode ver um ícone de alfinete à direita do nome do serviço definido como padrão, indicando que esta versão é a padrão.

Last Updated: 11/24/2023