# تعيين إصدارات الحزم الافتراضية

في ServBay، يمكنك تعيين إصدارات الحزم الافتراضية لـ دعم سطر الأوامر لاستخدامها افتراضيًا عند تشغيل الأوامر في سطر الأوامر أو النصوص ذات الصلة، داعمة لـ PHP وMariaDB وPostgreSQL، وغيرها. فيما يلي التعليمات المفصلة لتعيين إصدارات الحزم الافتراضية:

  1. افتح ServBay.

  2. انقر على "الإعدادات" في شريط التنقل الأيسر.

  3. في صفحة الإعدادات، ابحث عن خيار "الإصدار الافتراضي".

  4. في الخيارات المنسدلة، اختر الإصدارات الافتراضية لـ PHP وMariaDB وPostgreSQL على التوالي.

  5. انقر على زر "تطبيق" لتطبيق التغييرات.

بعد تعيين الإصدارات الافتراضية، على سبيل المثال، إذا قمت بتعيين إصدار PHP الافتراضي إلى 7.4، سينتج تشغيل php -v في سطر الأوامر PHP 7.4.x (cli).

إذا كنت بحاجة إلى تنفيذ إصدار غير افتراضي مؤقتًا في سطر الأوامر، مثل PHP 8.1، يمكنك استدعاء الإصدار 8.1 باستخدام الأمر php-8.1، على سبيل المثال php-8.1 -v، والذي سينتج PHP 8.1.x (cli).

تنطبق الإعدادات المماثلة على MariaDB وPostgreSQL وغيرها من الحزم. يرجى ملاحظة أنه في صفحة إدارة الخدمة، يمكنك رؤية رمز الدبوس إلى يمين اسم الخدمة المحدد كإصدار افتراضي، مشيرًا إلى أن هذا الإصدار هو الإصدار الافتراضي.

Last Updated: 11/25/2023