# Définir les Versions par Défaut des Packages

Dans ServBay, vous pouvez définir les versions par défaut des packages pour le support de la ligne de commande à utiliser par défaut lors de l'exécution de commandes en ligne de commande ou de scripts associés, prenant en charge PHP, MariaDB, PostgreSQL, et plus encore. Voici les instructions détaillées pour définir les versions par défaut des packages :

  1. Ouvrez ServBay.

  2. Cliquez sur "Paramètres" dans la barre de navigation latérale.

  3. Dans la page des paramètres, trouvez l'option "Version par Défaut".

  4. Dans les options déroulantes, choisissez les versions par défaut pour PHP, MariaDB et PostgreSQL, respectivement.

  5. Cliquez sur le bouton "Appliquer" pour appliquer les changements.

Après avoir défini les versions par défaut, par exemple, si vous définissez la version par défaut de PHP sur 7.4, l'exécution de php -v en ligne de commande affichera PHP 7.4.x (cli).

Si vous devez exécuter temporairement une version non par défaut en ligne de commande, telle que PHP 8.1, vous pouvez invoquer la version 8.1 en utilisant la commande php-8.1, comme php-8.1 -v, qui affichera PHP 8.1.x (cli).

Des paramètres similaires s'appliquent à MariaDB, PostgreSQL et d'autres packages. Notez que dans la gestion des services, vous pouvez voir une icône d'épingle à droite du nom du service défini comme la version par défaut, indiquant que cette version est la version par défaut.

Last Updated: 11/25/2023